Domo - Icon Pack
9.3
153

Domo - Icon Pack

3.1.2 by kovdev
Perspective. Touch. Feel. Love. These icons will pop on your home screens.
Price: $1.99

Domo - Icon Pack Screenshots

Domo - Icon Pack 3.1.2 Description
Domo - Icon Pack (Package Name: kov.theme.domo) is developed by kovdev and the latest version of Domo - Icon Pack 3.1.2 was updated on October 15, 2016. Domo - Icon Pack is in the category of Personalization. You can check all apps from the developer of Domo - Icon Pack and find 52 alternative apps to Domo - Icon Pack on Android. The current price of this app is $1.99.This app can be downloaded on 4.0.3 and up on APKFab or Google Play. All APK / XAPK files on APKFab.com are original and 100% safe with fast download.
Perspective. Touch. Feel. Love. Those are the founding principles of this latest design. When approaching these icons, we really wanted to have them stand out on the device. We've crafted a curved chiclet-style base, to serve as the main anchor. From there, the glyphs rise off the surface while casting a soft shadow. All of these little touches combine into a solid feeling design, ready to help your home screens pop in all new ways.
Over 2300 icons made in beautiful QHD resolution and a complete set of wallpapers, served directly from the cloud. We've got search available, to help you find exactly the icon you need.
Not sure if we support your launcher? Have any other questions? Feel free to check out the help section, included in the icon pack dashboard. If you can't find the answer you are looking for, contact us!
/// CONNECT WITH US
G+ Community: http://kvdv.co/community
Twitter: http://www.twitter.com/kovdev
Facebook: http://www.facebook.com/kovdev
Google+: http://plus.google.com/+kovdev
Google Now Launcher is not compatible as it does not support icon packs. We recommend Nova.
Tags: #Nova.theme
Read More
Domo - Icon Pack Features
More Information
Package Name:

kov.theme.domo

Update Date:

2016-10-15

Latest Version:

3.1.2 

Need Update:

Submit latest version

Available on:

Google Play

Requirements:

4.0.3 and up